HOME » Natsu note » Xcode » [Xcode][iOS] Xcode 4.2にiOSシミュレータ4.3をインストールする

[Xcode][iOS] Xcode 4.2にiOSシミュレータ4.3をインストールする 2011/10/17/|Xcode,

先日リリースされた正式バージョンのXcode 4.2 + iOS SDK 5.0。お気づきだとは思いますが、シミュレータが5.0のものしかありません。

そうは言っても、まだまだOSバージョン4.xをサポートしている方は多いでしょう。そんなときは、Xcode 4.2にiOSシミュレータ4.3をインストールしましょう。

インストール方法は簡単。XcodeのPreferences…(Command+,)で環境設定を表示し、Downloadsタブを選びます。ここからiOS4.3のシミュレータがダウンロード可能です。これで無事にiOS4.3のiPhone, iPadシミュレータが動作するようになります。

Xcode 4.2 Dowonload iOS 4.3 Simulator


また、同時に、iOS3.0以降のDevice Debugging Supportもダウンロード可能なので、旧バージョンのOSの実機デバッグをする場合、こちらからダウンロードしておくとよいでしょう。

iOS4.3よりも古いシミュレータは今のところダウンロードできないようですね。過去のSDK(/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/)をコピーすれば一応動作はしていますが、正常なのかはよくわかりません。試してみる方は自己責任でお願いします。